How to Find the Release Version of Your Linux/Unix

It is very difficult to remember the release version for each of unix servers if you have a lot of different Linux distributions installed on many different machines. But, no worry as there is easy command that can help you to trace the release version of the unix operating system.

If you are on RHEL/CentOS

    [root@server ~]# cat /etc/redhat-release
    CentOS release 5.5 (Final)
    

If you are on Sun Solaris

    #cat /etc/release
    

If you are on SUSE Linux

    #cat /etc/SuSE-release
    

If you are on Ubuntu Linux

    #cat /etc/issue
    

How to Resolved Dependencies Related with wvText

wvText converts word documents into plain text, with formatting prominently similar to the original document. It commonly used as a dependencies software for some documentation system such as gforge server. To resolve wvText, you just need to run this yum command on your linux terminal.

1. Prepare the epel repository to enable you to use yum install for wv.

64 Bit Operating System

[root@myserver tmp]# wget http://download.fedora.redhat.com/pub/epel/5/x86_64/
epel-release-5-4.noarch.rpm

32 Bit Operating System:

[root@myserver tmp]# wget http://download.fedora.redhat.com/pub/epel/5/i386/
epel-release-5-4.noarch.rpm
[root@server tmp]# rpm -Uvh epel-release-5-4.noarch.rpm

2. Run Yum install command :

[root@server ~]# yum install wv
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * addons: centos.maulvi.net
 * base: centos.maulvi.net
 * epel: mirror.neu.edu.cn
 * extras: centos.maulvi.net
 * updates: ossm.utm.my
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package wv.i386 0:1.2.4-4.el5 set to be updated
--> Processing Dependency: libgsf-1.so.114 for package: wv
--> Running transaction check
---> Package libgsf.i386 0:1.14.1-6.1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================
 Package                              Arch                               Version
==========================================================================================
Installing:
 wv                                   i386                               1.2.4-4.el5
Installing for dependencies:
 libgsf                               i386                               1.14.1-6.1

Transaction Summary
==========================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total download size: 383 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): libgsf-1.14.1-6.1.i386.rpm                                  | 116 kB     00:01
(2/2): wv-1.2.4-4.el5.i386.rpm                                     | 120 kB     01:04
http://mirror.neu.edu.cn/fedora/epel/5/i386/wv-1.2.4-4.el5.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(2/2): wv-1.2.4-4.el5.i386.rpm                                     | 267 kB     00:05
------------------------------------------------------------------------------------------
Total                                                     4.4 kB/s | 383 kB     01:27
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : libgsf                                                             1/2
  Installing     : wv                                                                 2/2

Installed:
  wv.i386 0:1.2.4-4.el5

Dependency Installed:
  libgsf.i386 0:1.14.1-6.1

Complete!

How to Resolved Dependencies for pdftotext if Not Found

In certain condition, pdftotext is required to be installed on linux operation system. Pdftotext utility can convert Portable Document Format (PDF) files to plain text. It reads the PDF file, and writes a text file. In linux, this commonly use as the dependencies and it compulsary for some system like Gforge Community Edition and Gforge Advance Server. I just found the solution on how to resolved the dependencies issue while trying to install Gforge Advance Server. You just need to run below command.

    [root@server ~]# yum install poppler-utils
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
     * addons: centos.maulvi.net
     * base: centos.maulvi.net
     * epel: mirror.neu.edu.cn
     * extras: centos.maulvi.net
     * updates: ossm.utm.my
    Setting up Install Process
    Resolving Dependencies
    --> Running transaction check
    ---> Package poppler-utils.i386 0:0.5.4-4.4.el5_6.17 set to be updated
    --> Processing Dependency: poppler = 0.5.4-4.4.el5_6.17 for package: poppler-utils
    --> Processing Dependency: libpoppler.so.1 for package: poppler-utils
    --> Running transaction check
    ---> Package poppler.i386 0:0.5.4-4.4.el5_6.17 set to be updated
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ==========================================================================================
     Package                Arch          Version                      Repository        Size
    ==========================================================================================
    Installing:
     poppler-utils          i386          0.5.4-4.4.el5_6.17           updates           73 k
    Installing for dependencies:
     poppler                i386          0.5.4-4.4.el5_6.17           updates          3.0 M
    
    Transaction Summary
    ==========================================================================================
    Install       2 Package(s)
    Upgrade       0 Package(s)
    
    Total download size: 3.1 M
    Is this ok [y/N]: y
    Downloading Packages:
    (1/2): poppler-utils-0.5.4-4.4.el5_6.17.i386.rpm                   |  73 kB     00:01
    (2/2): poppler-0.5.4-4.4.el5_6.17.i386.rpm                         | 3.0 MB     00:58
    ------------------------------------------------------------------------------------------
    Total                                                      52 kB/s | 3.1 MB     01:01
    Running rpm_check_debug
    Running Transaction Test
    Finished Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing     : poppler                                                            1/2
      Installing     : poppler-utils                                                      2/2
    
    Installed:
      poppler-utils.i386 0:0.5.4-4.4.el5_6.17
    
    Dependency Installed:
      poppler.i386 0:0.5.4-4.4.el5_6.17
    
    Complete!
    

How to Fix “An old version of the database format was found” While Starting PostgreSQL

I would like to share with you on how to fix “An old version of the database format was found” While Starting PostgreSQL server. This error usually happen after we upgrade the postgresql from the lower version to higher version. As an example, we upgrade the postgresql version 8.2 to postgresql version 8.4.1 as below. You will get an error while you starting the postgresql.

Symptoms:
This error will appeared when starting the postgresql service

    [root@server ~]# service postgresql start
    
    An old version of the database format was found.
    You need to upgrade the data format before using PostgreSQL.
    See /usr/share/doc/postgresql-8.4.1/README.rpm-dist for more information.
    

Solution:
1. Assume that you have successfully backup the postgresql database.
2. Run this command.

    [root@server ~]# cd /var/lib/pgsql/data
    [root@server data]# ls
    base    pg_clog      pg_ident.conf  pg_multixact  pg_tblspc    PG_VERSION  postgresql.conf
    global  pg_hba.conf  pg_log         pg_subtrans   pg_twophase  pg_xlog     postmaster.opts
    [root@server data]# rm -rf *
    

Reinitialize the database.

    [root@server data]# service postgresql initdb
    Initializing database:                                     [  OK  ]
    

or you can proceed to directly start the database service.

    [root@server data]# service postgresql start
    Starting postgresql service:                               [  OK  ]
    

How to Configure Email on Android

In this article i will guide you on how to configure your email on an Android device.
1. Click POP3/IMAP
email
2. Enter Email address and password
email
3. Select Incoming mail Protocol. In this case, Select IMAP.
email
4. Please fill in Outgoing server setting.
email
5. Verify your account is correct and if you want to make this email as a default, please check box.
email
6. You are done.
email

How to Test your Internet Broadband Speed on Android Using Speedtest.net Mobile

In this article, i will show you on how to test the internet broadband speed on your android smartphone using speedtest apps. Speedtest.net Mobile is a android version of the most popular broadband speed test on the internet. It’s use to measure the network speed on your android device.

Follow below steps to download the apps from Android Market

* Open Android Market on Your phone
* Go to “Search”
* Type “speedtest.net” in the search field and hit “Search”
* Once you find the “speedtest.net” app, choose “Install” and follow the instructions

1. Once installed, click  “Begin Test” to start.
Speedtest.net
2. Click “Restart Test” if you want to restart the network speed test.
Speedtest.net

3. If you want to change the server, click “Setting” then click “Change Server“.
Speedtest.net
4. Select prefer server location. Click “Select Server“.
Speedtest.net

5. Click “Result” if you want to see the test result and the previous result.
Speedtest.net

How to Download Youtube Video on Android Smart Phone Using TubeX

TubeX is the fastest youtube video downloader and it has a very fast download speeds, because it uses concurrent threads, multi connections, resume breakpoints download technology,etc.

Follow below steps to download the apps from Android Market

* Open Android Market on Your phone
* Go to “Search”
* Type “TubeX” in the search field and hit “Search”
* Once you find the “Tubex” app, choose “Install” and follow the instructions

If you already installed the TubeX please follow below steps.
1. Click TubeX apps and search for your favorite video.
TubeX
2. After you click the selected video, it will prompt you 3 options. Click Download to proceed.
TubeX

3. Select the prefer resolution and your video will automatically downloaded.
TubeX

4. Click Download tab to see downloading video.
TubeX

Release Notes
[ Version 1.6 ] 05/31/2011

1. Fixed lost the downloaded file when upgrade version 1.5.
2. Fixed other minor bugs.

[ Version 1.5 ] 05/26/2011

1. Fixed ‘too many download tasks’ bug.
2. Fixed force close bugs.

[ Version 1.4 ] 04/17/2011

1. Improve the ‘Download as MP3’ speed.
2. Added 640×360 video format.
3. Fixed the ‘Resume download’ bug in the Fast Download Mode.
4. Fixed some minor bugs.

[ Version 1.3 ] 04/13/2011

1. Fixed some minor bugs.

[ Version 1.2 ] 04/12/2011

1. Fixed ‘Change mp3 folder’ bugs.
2. Fixed ‘play video/mp3’ options.
3. Fixed other bugs.

[ Version 1.1 ] 04/08/2011

1. Add a variety of download formats(3gp,MP4,MP3,FLV,720P).
2. Fixed bugs.

[ Version 1.0 ] 04/01/2011

1. TubeX 1.0 published.
2. Added “Fast Download Mode” feature.

TubeX

How to Configure Blogspot Template

1. How to Configure Meta tags

Login to your blogger dashboard–> layout- -> Edit HTML.Now Scroll down to where you see below codes :

<meta content='DESCRIPTION HERE' name='description'/>
<meta content='KEYWORDS HERE' name='keywords'/>

Replace DESCRIPTION HERE,KEYWORDS HERE as below.

DESCRIPTION HERE:Write your blog description
KEYWORDS HERE:Write the keywords of your blog separated by comma.

2. How To Configure Favicon:

Login to your blogger dashboard–> layout- -> Edit HTML.Now Scroll down to where you see below code :

<link href='YOUR-FAVICON-URL' rel='shortcut icon' type='image/vnd.microsoft.icon'/>

Now replace “YOUR-FAVICON-URL” with your Favicon address/url.

3. Configure Featured Content Slider:

Login to your blogger dashboard–> layout- -> Edit HTML.Find <!– Featured Content Slider Started –>.Now scroll down slowly and you can see each featured slide codes between <div class=’fp-post’> and </div> .

Now replace,

  • “This is default featured post X title” with your featured post title.
  • “featured-post-X-url-here” with your featured post URL.
  • “Go to Blogger edit html and find these sentences.Now replace these sentences with your own descriptions.
  • Slider image address with your slider image.

for each featured slide.

4. How To Configure Second Navigation Menu

Find <div class=’menu-secondary-wrap’> inside your template.(using CTRL+F).This is the beginning of the navigation menu.Now follow the steps given here:

5. How To Change Tab Names of Tab Widget

If you want to change your tab names of your tab widget then find this:

<ul class='tabs-widget tabs-widget-widget-themater_tabs-1432447472-id'>
<li><a href='#widget-themater_tabs-1432447472-id1'>Popular</a></li>
<li><a href='#widget-themater_tabs-1432447472-id2'>Tags</a></li>
<li><a href='#widget-themater_tabs-1432447472-id3'>Blog Archives</a></li>
</ul>

Now change the names “Populars”, “Tags” and “Blog Archives” as you like.

6. How To Add a Header Logo

You can add a header logo for this template easily in the “Page Elements” section(Blogger Default Method).Logo image size must be 275px width and 64px height.

How to Uninstall Webmin in CentOS 5.5

I will show you on how to uninstall the webmin from CentOS server. Just run below command :

    [root@server ~]# /etc/webmin/uninstall.sh
    Are you sure you want to uninstall Webmin? (y/n) : y
    
    Stopping Webmin server in /tmp/webmin-1.550
    Running uninstall scripts ..
    /etc/webmin/uninstall.sh: line 8: /tmp/webmin-1.550/run-uninstalls.pl: No such file or directory
    Deleting /tmp/webmin-1.550 ..
    Deleting /etc/webmin ..
    Done!
    

How to Add Post Footer to WordPress

These are a few steps to add post footer in WordPress post:

Steps
1. Go to plugin menu
2. Click Add New and
3. On the search box, type term –> add post footer, then click search plugin
4. It will show you one plugin called “Add Post Footer”, and click install. Then activate the plugin.
5. Once activated, go to setting menu, then click ” Post footer”
6. On these page, you will be able to customize the setting such as below :

  • Add Ad before Related Post: Select Yes/No
  • Add following Ad. code to the end of post: Select Yes/No
  • Add Ad Code Script:
  • Add related post list: Select Yes/No
  • Add Maximum number of post in the list:
  • Add The header text for post list: