How to Configure Static IP Address on CentOS 6.4

When you run one or more of any type of Web, DNS, Email, FTP or any other application server’s directly on your site, then you are require Static IP address. If you run a website hosting in Virtual Private Server (VPS), end user will types the domain name (e.g www.example.com) into their web browser it is translated via a DNS service to a specific IP address of your web server. Rules of thumb, any type of server is mandatory to have static IP Address because it is constant, otherwise the end user or the websites visitors will experience inaccessible website. This post will share how to setup Static IP Address on CentOS 6.4.

1. Configure static IP address on eth0 :

[root@centos64 ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth0

Original :

DEVICE=eth0
HWADDR=00:0C:29:F1:24:F0
TYPE=Ethernet
UUID=324bfeb3-2a7c-409c-98d0-5cf1607596c4
ONBOOT=no
NM_CONTROLLED=yes
BOOTPROTO=dhcp

Set to the following :

DEVICE=eth0
HWADDR=00:0C:29:F1:24:F0
TYPE=Ethernet
UUID=324bfeb3-2a7c-409c-98d0-5cf1607596c4
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=none
IPADDR=192.168.2.62
NETMASK=255.255.0.0

2. Configure gateway :

[root@centos64 ~]# vi /etc/sysconfig/network

Add gateway line :

NETWORKING=yes
HOSTNAME=centos64.ehowstuff.local
GATEWAY=192.168.2.1

3. Configure DNS :

; generated by /sbin/dhclient-script
search Belkin ehowstuff.local
nameserver 192.168.2.1

Update to the following :

search ehowstuff.local
nameserver 8.8.8.8

4. Restart network service to apply the changes :

[root@centos64 ~]# service network restart
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]

9 Steps to Setup Dedicated Server for your Website

dedicated serverThere are different types of hosting services are used in the computer technology such as shared hosting, VPS (Virtual Private Server) and Dedicated Server hosting. For new websites with low numbers of visitors, I would highly recommend getting a shared hosting. If you need more control of the server, then you should moving from shared hosting to a VPS. There are plenty of hosting companies offering Virtual Private Servers, and VPS hosting is getting cheaper. This blog hosted at RamNode VPS.

At some point, your site will get super slow server performance impact on limited resources when running VPS hosting. More server resources required is due to the increased number of visitors to the tens of thousands or hundreds of thousands per day.

At the situation when you are hitting super slow website performance due to huge numbers of traffic, I would recommend you to getting dedicated servers. Cheaper way is to setup VPS additional to balance the load. If cost is not an issue, I always recommend you to purchase a dedicated server as this will give you excellent processing performance. In a dedicated server environment , resources such as memory , hard drive storage capacity, processing power, and network access are all 100% to dedicated servers instead of shared with multiple VPS or dozens of shared hosting customers. Popular websites on the Internet certainly have excellent servers behind them. Without such an excellent server, web sites with high concurrency of visitors will not be able to survive.

If you are an experienced system administrator, the following articles may not attract you, but for web developers and those new to the web hosting, the following article can be a useful guide on their first steps. I believe the popular website on the internet has been setup by a consultant who specializes in servers or installed by an experienced system administrator. In this article, I would like to share 9 steps to setup Dedicated Server for your Website.

Once you have purchased a dedicated server, you can log in to your server to complete the setup of your server from start to finish. Below is a guide and checklist for you who are new to server administration.

9 Steps to Setup Dedicated Server

1. Choose and Install Linux operating system :

Choosing the right platform on which to host your dedicated server. Please make sure that you are familiar with the preferred operating system (OS) either CentOS or Fedora or Ubuntu or maybe Windows OS. If you choose linux OS, I would recommend you to do a clean minimal installed of the OS.

2. Update operating system :

Make sure that the OS has been applied the latest patches.
How to Update CentOS 6.4 System using ‘yum update’

3. Install Apache or Nginx Web server :

Apache httpd is one of the most popular web servers and has a lot of features that make it very extensible and useful for many different types of websites. As an alternative to Apache http server, you also can install NGINX. Nginx or “engine x” is a free, open-source HTTP server that provide high-performance edge web server with the lowest memory footprint and the key features to build modern and efficient web infrastructure. I used Nginx to run this blog.

How to Setup Nginx With PHP-FastCGI on CentOS 6.2/CentOS 6.3 VPS Server

4. Install MySQL Database server :

MySQL server is a database server that can stores and retrieves data for the blog, websites and applications. It is one of the most popular most used in the internet especially for content management and blogging site.

5. Install PHP :

PHP: Hypertext Preprocessor is a widely used, free and open-source server-side scripting language that was especially designed for web development to produce dynamic web pages and can be embedded into HTML.

6. Install Bind DNS server :

BIND (the Berkeley Internet Name Domain) also known as NAMED is the most widely used DNS server in the internet. Bind DNS helps to resolve domain name to ip address and ip address to domain name.

7. Install FTP server :

File Transfer Protocol (FTP) is a network protocol used transfer file in the network. one of the most popular FTP server for Unix/Linux is vsftpd. Vsftpd stand for Very Secure FTP Daemon. Vsftpd not only just another popular FTP server for Unix/Linux systems, but vsftpd delivers excellent performance by consuming less memory.

8. Harden and Secure the dedicated server :

There are a few steps to harden the OS of dedicated server.
a) Install a host based firewall to protect your dedicated server from unauthorized access:
Once you have your web server running, you have to install host based firewall and open only certain port in your firewall. I would recommend you tosetting up iptables on your linux dedicated server.

b) Use Strong passwords :
Password complexity requirements should be in place to enforce strong password. A strong password should have mixed case, special characters, numbers, and be longer than 8 characters. Additional security, the passwords should be changed regularly.

c) Disable Unnecessary Processes, Services and Daemons :
I would recommend you to disable unneeded processes,services and daemon such as bluetooth, hidd, cups, yum-updatesd, ypbind, nfs, snmpd, saslauthd, netfs, gpm, pcmcia and sendmail. SELinux also should be set to “Disabled”. This is still very experimental so I would leave this disabled unless you really know what you are doing.

9. Install or migrate over the content of your website or blog :

You can start to migrate over the content of your website or blog to your new dedicated server. For dynamic content blog, i would recommend you to use WordPress as a platform. WordPress is an open-source blogging platform. It’s a free blogging tool and content management system (CMS) based on PHP and MySQL.

I hope that this 9 steps to setup dedicated server can be a useful guide on your first steps to have your own dedicated server to run a websites.

How to Update CentOS 6.4 System using ‘yum update’

Linux LogoThis post will show how you can update CentOS 6.4 system with ‘yum‘ command. You should update the linux to newer release or latest linux kernal because you will get security fixes, stability improvements, updated device drivers, get new kernel functions and to increased speed of the linux operating system. After get all above benefits, it’s very worthwhile to update your kernel for Linux often as soon as new update released. Now let’s take a look at the most common linux command that we can use for updating linux system. This steps has been tested on CentOS 6.4.

1 Get ‘yum-plugin-fastestmirror’ plugin installed. This plugin will looks for fast server to download packages :

[root@centos64 ~]# yum install yum-plugin-fastestmirror -y

2. Check current version and current kernel version :

[root@centos64 ~]# cat /etc/redhat-release
CentOS release 6.4 (Final)
[root@centos64 ~]# uname -a
Linux centos64.ehowstuff.local 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

3. Perform system update by ‘yum update’ command :

[root@centos64 ~]# yum update -y

Example :

[root@centos64 ~]# yum update -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.ipserverone.com
 * extras: centos.ipserverone.com
 * updates: centos.ipserverone.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package dbus-glib.x86_64 0:0.86-5.el6 will be updated
---> Package dbus-glib.x86_64 0:0.86-6.el6 will be an update
---> Package kernel.x86_64 0:2.6.32-358.2.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-358.2.1.el6 will be an update
---> Package libxml2.x86_64 0:2.7.6-8.el6_3.4 will be updated
---> Package libxml2.x86_64 0:2.7.6-12.el6_4.1 will be an update
---> Package mysql-libs.x86_64 0:5.1.66-2.el6_3 will be updated
---> Package mysql-libs.x86_64 0:5.1.67-1.el6_3 will be an update
---> Package openldap.x86_64 0:2.4.23-31.el6 will be updated
---> Package openldap.x86_64 0:2.4.23-32.el6_4 will be an update
---> Package openssl.x86_64 0:1.0.0-27.el6 will be updated
---> Package openssl.x86_64 0:1.0.0-27.el6_4.2 will be an update
---> Package selinux-policy.noarch 0:3.7.19-195.el6 will be updated
---> Package selinux-policy.noarch 0:3.7.19-195.el6_4.3 will be an update
---> Package selinux-policy-targeted.noarch 0:3.7.19-195.el6 will be updated
---> Package selinux-policy-targeted.noarch 0:3.7.19-195.el6_4.3 will be an update
---> Package tzdata.noarch 0:2012j-1.el6 will be updated
---> Package tzdata.noarch 0:2012j-2.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package                            Arch              Version                        Repository          Size
==============================================================================================================
Installing:
 kernel                             x86_64            2.6.32-358.2.1.el6             updates             26 M
Updating:
 dbus-glib                          x86_64            0.86-6.el6                     updates            170 k
 kernel-firmware                    noarch            2.6.32-358.2.1.el6             updates             11 M
 libxml2                            x86_64            2.7.6-12.el6_4.1               updates            799 k
 mysql-libs                         x86_64            5.1.67-1.el6_3                 updates            1.2 M
 openldap                           x86_64            2.4.23-32.el6_4                updates            265 k
 openssl                            x86_64            1.0.0-27.el6_4.2               updates            1.4 M
 selinux-policy                     noarch            3.7.19-195.el6_4.3             updates            1.8 M
 selinux-policy-targeted            noarch            3.7.19-195.el6_4.3             updates            2.8 M
 tzdata                             noarch            2012j-2.el6                    updates            453 k

Transaction Summary
==============================================================================================================
Install       1 Package(s)
Upgrade       9 Package(s)

Total download size: 46 M
Downloading Packages:
(1/10): dbus-glib-0.86-6.el6.x86_64.rpm                                                | 170 kB     00:01
(2/10): kernel-2.6.32-358.2.1.el6.x86_64.rpm                                           |  26 MB     04:11
(3/10): kernel-firmware-2.6.32-358.2.1.el6.noarch.rpm                                  |  11 MB     01:45
(4/10): libxml2-2.7.6-12.el6_4.1.x86_64.rpm                                            | 799 kB     00:06
(5/10): mysql-libs-5.1.67-1.el6_3.x86_64.rpm                                           | 1.2 MB     00:11
(6/10): openldap-2.4.23-32.el6_4.x86_64.rpm                                            | 265 kB     00:05
(7/10): openssl-1.0.0-27.el6_4.2.x86_64.rpm                                            | 1.4 MB     00:12
(8/10): selinux-policy-3.7.19-195.el6_4.3.noarch.rpm                                   | 1.8 MB     00:17
(9/10): selinux-policy-targeted-3.7.19-195.el6_4.3.noarch.rpm                          | 2.8 MB     00:27
(10/10): tzdata-2012j-2.el6.noarch.rpm                                                 | 453 kB     00:07
--------------------------------------------------------------------------------------------------------------
Total                                                                         105 kB/s |  46 MB     07:27
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA1 Signature, key ID c105b9de: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Importing GPG key 0xC105B9DE:
 Userid : CentOS-6 Key (CentOS 6 Official Signing Key) 
 Package: centos-release-6-4.el6.centos.10.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : openssl-1.0.0-27.el6_4.2.x86_64                                                           1/19
  Updating   : selinux-policy-3.7.19-195.el6_4.3.noarch                                                  2/19
  Updating   : kernel-firmware-2.6.32-358.2.1.el6.noarch                                                 3/19
  Installing : kernel-2.6.32-358.2.1.el6.x86_64                                                          4/19
  Updating   : selinux-policy-targeted-3.7.19-195.el6_4.3.noarch                                         5/19
  Updating   : mysql-libs-5.1.67-1.el6_3.x86_64                                                          6/19
  Updating   : openldap-2.4.23-32.el6_4.x86_64                                                           7/19
  Updating   : tzdata-2012j-2.el6.noarch                                                                 8/19
  Updating   : dbus-glib-0.86-6.el6.x86_64                                                               9/19
  Updating   : libxml2-2.7.6-12.el6_4.1.x86_64                                                          10/19
  Cleanup    : selinux-policy-targeted-3.7.19-195.el6.noarch                                            11/19
  Cleanup    : selinux-policy-3.7.19-195.el6.noarch                                                     12/19
  Cleanup    : tzdata-2012j-1.el6.noarch                                                                13/19
  Cleanup    : kernel-firmware-2.6.32-358.el6.noarch                                                    14/19
  Cleanup    : mysql-libs-5.1.66-2.el6_3.x86_64                                                         15/19
  Cleanup    : openssl-1.0.0-27.el6.x86_64                                                              16/19
  Cleanup    : openldap-2.4.23-31.el6.x86_64                                                            17/19
  Cleanup    : dbus-glib-0.86-5.el6.x86_64                                                              18/19
  Cleanup    : libxml2-2.7.6-8.el6_3.4.x86_64                                                           19/19
  Verifying  : libxml2-2.7.6-12.el6_4.1.x86_64                                                           1/19
  Verifying  : kernel-firmware-2.6.32-358.2.1.el6.noarch                                                 2/19
  Verifying  : dbus-glib-0.86-6.el6.x86_64                                                               3/19
  Verifying  : selinux-policy-3.7.19-195.el6_4.3.noarch                                                  4/19
  Verifying  : tzdata-2012j-2.el6.noarch                                                                 5/19
  Verifying  : mysql-libs-5.1.67-1.el6_3.x86_64                                                          6/19
  Verifying  : openssl-1.0.0-27.el6_4.2.x86_64                                                           7/19
  Verifying  : kernel-2.6.32-358.2.1.el6.x86_64                                                          8/19
  Verifying  : openldap-2.4.23-32.el6_4.x86_64                                                           9/19
  Verifying  : selinux-policy-targeted-3.7.19-195.el6_4.3.noarch                                        10/19
  Verifying  : tzdata-2012j-1.el6.noarch                                                                11/19
  Verifying  : kernel-firmware-2.6.32-358.el6.noarch                                                    12/19
  Verifying  : selinux-policy-3.7.19-195.el6.noarch                                                     13/19
  Verifying  : openssl-1.0.0-27.el6.x86_64                                                              14/19
  Verifying  : selinux-policy-targeted-3.7.19-195.el6.noarch                                            15/19
  Verifying  : mysql-libs-5.1.66-2.el6_3.x86_64                                                         16/19
  Verifying  : libxml2-2.7.6-8.el6_3.4.x86_64                                                           17/19
  Verifying  : openldap-2.4.23-31.el6.x86_64                                                            18/19
  Verifying  : dbus-glib-0.86-5.el6.x86_64                                                              19/19

Installed:
  kernel.x86_64 0:2.6.32-358.2.1.el6

Updated:
  dbus-glib.x86_64 0:0.86-6.el6                     kernel-firmware.noarch 0:2.6.32-358.2.1.el6
  libxml2.x86_64 0:2.7.6-12.el6_4.1                 mysql-libs.x86_64 0:5.1.67-1.el6_3
  openldap.x86_64 0:2.4.23-32.el6_4                 openssl.x86_64 0:1.0.0-27.el6_4.2
  selinux-policy.noarch 0:3.7.19-195.el6_4.3        selinux-policy-targeted.noarch 0:3.7.19-195.el6_4.3
  tzdata.noarch 0:2012j-2.el6

Complete!

How to Add Network Adapter Without Reboot on CentOS 6/RHEL 6

This article will explain how to prepare more than one network interface on a VMware virtual machine (VM) without reboot the linux server. Normally, a network interface is sufficient to run a linux server. To ensure a balance of traffic or to enable multiple network segments in a VM, it is advisable to install more than one interface card. It was assumed that the card eth0 is configured properly and working. The process of adding a second network interface card is very easy in VMware ESXi / ESX and VMware workstation. What you need is through the vCenter or ESXi host, start the add hardware wizard and then select “Network Adapter” and let the wizard complete successfully. The following are the tested steps on CentOS 6.4 and may be applied on CentOS 6.5 and CentOS 6.6 operating system.

1. Check existing network setting.

[root@centos64 ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:29:F1:24:F0
          inet addr:192.168.2.62  Bcast:192.168.255.255  Mask:255.255.0.0
          inet6 addr: fe80::20c:29ff:fef1:24f0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:735 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:72242 (70.5 KiB)  TX bytes:8635 (8.4 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

2. Enter network configuration folder, and look for ethx file. By default, first network interface will start with eth0. Next added network adapter will be eth1.

[root@centos64 ~]# cd /etc/sysconfig/network-scripts/
[root@centos64 network-scripts]# ls
ifcfg-eth0   ifdown-ippp  ifdown-routes  ifup-bnep  ifup-plip    ifup-sit          network-functions
ifcfg-lo     ifdown-ipv6  ifdown-sit     ifup-eth   ifup-plusb   ifup-tunnel       network-functions-ipv6
ifdown       ifdown-isdn  ifdown-tunnel  ifup-ippp  ifup-post    ifup-wireless
ifdown-bnep  ifdown-post  ifup           ifup-ipv6  ifup-ppp     init.ipv6-global
ifdown-eth   ifdown-ppp   ifup-aliases   ifup-isdn  ifup-routes  net.hotplug

3. After you add secondary network interface from VMware level, the file will automatically added the mac address in /etc/udev/rules.d/70-persistent-net.rules. Please take note on the mac address for eth1.

[root@centos64 ~]# more /etc/udev/rules.d/70-persistent-net.rules
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x8086:0x100f (e1000)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:f1:24:f0", ATTR{type}=="1", KERNEL=="
eth*", NAME="eth0"

# PCI device 0x8086:0x100f (e1000)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:0c:29:f1:24:fa", ATTR{type}=="1", KERNEL=="
eth*", NAME="eth1"

4. Now you need to create the configuration file for your new interface. The network interface configuration files are placed in /etc/sysconfig/network-scripts/. change the mac address according based on /etc/udev/rules.d/70-persistent-net.rules.

[root@centos64 ~]# vi /etc/sysconfig/network-scripts/ifcfg-eth1

Add below setting :

DEVICE=eth1
HWADDR=00:0c:29:f1:24:fa
TYPE=Ethernet
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=none
IPADDR=192.168.2.63
NETMASK=255.255.0.0

5. Based on the type interface being added, issue an ifup command. In this case, we have added eth1.

[root@centos64 ~]# ifup eth1

6. Verify new Network interfaces :

[root@centos64 ~]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0C:29:F1:24:F0
          inet addr:192.168.2.62  Bcast:192.168.255.255  Mask:255.255.0.0
          inet6 addr: fe80::20c:29ff:fef1:24f0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8019 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6949 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:804606 (785.7 KiB)  TX bytes:694075 (677.8 KiB)

[root@centos64 ~]# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:0C:29:F1:24:FA
          inet addr:192.168.2.63  Bcast:192.168.255.255  Mask:255.255.0.0
          inet6 addr: fe80::20c:29ff:fef1:24fa/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:450 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:40087 (39.1 KiB)  TX bytes:1182 (1.1 KiB)

Linode Network Upgrades and 8 Cores Xen Instances

Linode Network Upgrade

Early of March 2013, Linode has performed network upgrade that improves throughput, decrease latency and
add redundancy at their host layer. They are upgrading overall network in all six datacenters in the US, Europe, and Asia-Pacific. With zero downtime, Linode customer will get outbound network cap increased 5 times and amount of outbound transfer increased 10 times as below :

Linode 512 upgraded from 200GB to 2000GB (2TB)
Linode 1G upgraded from 400GB to 4000GB (4TB)
Linode 2G upgraded from 800GB to 8000GB (8TB)
Linode 4G upgraded from 1600GB to 16000GB (16TB)
Linode 8G upgraded from 2000GB to 20000GB (20TB)

8 Cores Xen instances

8coreIn 18th March 2013, Linode has upgrading new “NextGen’ host hardware specification, CPUs and a fleet refresh. Linode has upgrades all Linodes to 8 cores Xen instances. Customer will require to schedule a downtime for reboot and then get doubling in computing power. Customer will get faster websites, services, and processing at the same price points. Another things that Linode need to improve is the drive speed. Will they go for SSDs in the future ?

How to Fix “Could not reliably determine the server’s fully qualified domain name”

apache-http-serverQuestion :
How to fix “Could not reliably determine the server’s fully qualified domain name” when starting apache httpd service ?

[root@centos64 ~]# service httpd start
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos64.ehowstuff.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Answer :

Step 1:

Update /etc/hosts and do server’s ip address resolvable to the fully qualified domain name(fqdn) or hostname.

[root@centos64 ~]# vi /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

192.168.2.62 centos64.ehowstuff.local

Step 2:

Restart apache httpd service :

[root@centos64 ~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

How to Install and Configure PHP 5.3.3 on CentOS 6.4

phpPHP is a widely-used and open-source server-side scripting language that was especially designed for web development to produce dynamic web pages and can be embedded into HTML. PHP applications are commonly found with the filename extensions .php, .php4, or .php5. You can read more information about PHP from their website at www.php.net. The following step will install full PHP package.

1. Install PHP using yum command :

[root@centos64 ~]# yum install php* -y

Example :

[root@centos64 ~]# yum install php* -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.ipserverone.com
 * extras: centos.ipserverone.com
 * updates: centos.ipserverone.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: httpd-mmn = 20051115 for package: php-5.3.3-22.el6.x86_64
--> Processing Dependency: httpd for package: php-5.3.3-22.el6.x86_64
---> Package php-bcmath.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-cli.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-common.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-dba.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-devel.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: automake for package: php-devel-5.3.3-22.el6.x86_64
--> Processing Dependency: autoconf for package: php-devel-5.3.3-22.el6.x86_64
---> Package php-embedded.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-enchant.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libenchant.so.1()(64bit) for package: php-enchant-5.3.3-22.el6.x86_64
---> Package php-fpm.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-gd.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libjpeg.so.62(LIBJPEG_6.2)(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libpng12.so.0()(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libjpeg.so.62()(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libfreetype.so.6()(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libXpm.so.4()(64bit) for package: php-gd-5.3.3-22.el6.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: php-gd-5.3.3-22.el6.x86_64
---> Package php-imap.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libc-client.so.2007()(64bit) for package: php-imap-5.3.3-22.el6.x86_64
---> Package php-intl.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libicuuc.so.42()(64bit) for package: php-intl-5.3.3-22.el6.x86_64
--> Processing Dependency: libicuio.so.42()(64bit) for package: php-intl-5.3.3-22.el6.x86_64
--> Processing Dependency: libicui18n.so.42()(64bit) for package: php-intl-5.3.3-22.el6.x86_64
--> Processing Dependency: libicudata.so.42()(64bit) for package: php-intl-5.3.3-22.el6.x86_64
---> Package php-ldap.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-mbstring.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-mysql.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-odbc.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libodbc.so.2()(64bit) for package: php-odbc-5.3.3-22.el6.x86_64
---> Package php-pdo.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-pear.noarch 1:1.9.4-4.el6 will be installed
---> Package php-pecl-apc.x86_64 0:3.1.9-2.el6 will be installed
---> Package php-pecl-apc-devel.x86_64 0:3.1.9-2.el6 will be installed
---> Package php-pecl-memcache.x86_64 0:3.0.5-4.el6 will be installed
---> Package php-pgsql.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libpq.so.5()(64bit) for package: php-pgsql-5.3.3-22.el6.x86_64
---> Package php-process.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-pspell.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libpspell.so.15()(64bit) for package: php-pspell-5.3.3-22.el6.x86_64
--> Processing Dependency: libaspell.so.15()(64bit) for package: php-pspell-5.3.3-22.el6.x86_64
---> Package php-recode.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: librecode.so.0()(64bit) for package: php-recode-5.3.3-22.el6.x86_64
---> Package php-snmp.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: net-snmp for package: php-snmp-5.3.3-22.el6.x86_64
--> Processing Dependency: libnetsnmp.so.20()(64bit) for package: php-snmp-5.3.3-22.el6.x86_64
---> Package php-soap.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-tidy.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: php-tidy-5.3.3-22.el6.x86_64
---> Package php-xml.x86_64 0:5.3.3-22.el6 will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: php-xml-5.3.3-22.el6.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: php-xml-5.3.3-22.el6.x86_64
---> Package php-xmlrpc.x86_64 0:5.3.3-22.el6 will be installed
---> Package php-zts.x86_64 0:5.3.3-22.el6 will be installed
--> Running transaction check
---> Package aspell.x86_64 12:0.60.6-12.el6 will be installed
---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed
---> Package automake.noarch 0:1.11.1-4.el6 will be installed
---> Package enchant.x86_64 1:1.5.0-4.el6 will be installed
--> Processing Dependency: libhunspell-1.2.so.0()(64bit) for package: 1:enchant-1.5.0-4.el6.x86_64
---> Package freetype.x86_64 0:2.3.11-14.el6_3.1 will be installed
---> Package httpd.x86_64 0:2.2.15-26.el6.centos will be installed
--> Processing Dependency: httpd-tools = 2.2.15-26.el6.centos for package: httpd-2.2.15-26.el6.centos.x86_64
--> Processing Dependency: apr-util-ldap for package: httpd-2.2.15-26.el6.centos.x86_64
--> Processing Dependency: /etc/mime.types for package: httpd-2.2.15-26.el6.centos.x86_64
--> Processing Dependency: libaprutil-1.so.0()(64bit) for package: httpd-2.2.15-26.el6.centos.x86_64
--> Processing Dependency: libapr-1.so.0()(64bit) for package: httpd-2.2.15-26.el6.centos.x86_64
---> Package libX11.x86_64 0:1.5.0-4.el6 will be installed
--> Processing Dependency: libX11-common = 1.5.0-4.el6 for package: libX11-1.5.0-4.el6.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.5.0-4.el6.x86_64
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be installed
---> Package libc-client.x86_64 0:2007e-11.el6 will be installed
---> Package libicu.x86_64 0:4.2.1-9.1.el6_2 will be installed
---> Package libjpeg-turbo.x86_64 0:1.2.1-1.el6 will be installed
---> Package libpng.x86_64 2:1.2.49-1.el6_2 will be installed
---> Package libtidy.x86_64 0:0.99.0-19.20070615.1.el6 will be installed
---> Package libxslt.x86_64 0:1.1.26-2.el6_3.1 will be installed
---> Package net-snmp.x86_64 1:5.5-44.el6 will be installed
--> Processing Dependency: libsensors.so.4()(64bit) for package: 1:net-snmp-5.5-44.el6.x86_64
---> Package net-snmp-libs.x86_64 1:5.5-44.el6 will be installed
---> Package postgresql-libs.x86_64 0:8.4.13-1.el6_3 will be installed
---> Package recode.x86_64 0:3.6-28.1.el6 will be installed
---> Package unixODBC.x86_64 0:2.2.14-12.el6_3 will be installed
--> Processing Dependency: libltdl.so.7()(64bit) for package: unixODBC-2.2.14-12.el6_3.x86_64
--> Running transaction check
---> Package apr.x86_64 0:1.3.9-5.el6_2 will be installed
---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installed
---> Package httpd-tools.x86_64 0:2.2.15-26.el6.centos will be installed
---> Package hunspell.x86_64 0:1.2.8-16.el6 will be installed
---> Package libX11-common.noarch 0:1.5.0-4.el6 will be installed
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package libxcb.x86_64 0:1.8.1-1.el6 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.8.1-1.el6.x86_64
---> Package lm_sensors-libs.x86_64 0:3.1.1-17.el6 will be installed
---> Package mailcap.noarch 0:2.1.31-2.el6 will be installed
--> Running transaction check
---> Package libXau.x86_64 0:1.0.6-4.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package                       Arch              Version                             Repository          Size
==============================================================================================================
Installing:
 php                           x86_64            5.3.3-22.el6                        base               1.1 M
 php-bcmath                    x86_64            5.3.3-22.el6                        base                34 k
 php-cli                       x86_64            5.3.3-22.el6                        base               2.2 M
 php-common                    x86_64            5.3.3-22.el6                        base               524 k
 php-dba                       x86_64            5.3.3-22.el6                        base                40 k
 php-devel                     x86_64            5.3.3-22.el6                        base               507 k
 php-embedded                  x86_64            5.3.3-22.el6                        base               1.1 M
 php-enchant                   x86_64            5.3.3-22.el6                        base                28 k
 php-fpm                       x86_64            5.3.3-22.el6                        base               1.1 M
 php-gd                        x86_64            5.3.3-22.el6                        base               106 k
 php-imap                      x86_64            5.3.3-22.el6                        base                50 k
 php-intl                      x86_64            5.3.3-22.el6                        base                70 k
 php-ldap                      x86_64            5.3.3-22.el6                        base                38 k
 php-mbstring                  x86_64            5.3.3-22.el6                        base               455 k
 php-mysql                     x86_64            5.3.3-22.el6                        base                81 k
 php-odbc                      x86_64            5.3.3-22.el6                        base                50 k
 php-pdo                       x86_64            5.3.3-22.el6                        base                75 k
 php-pear                      noarch            1:1.9.4-4.el6                       base               393 k
 php-pecl-apc                  x86_64            3.1.9-2.el6                         base                96 k
 php-pecl-apc-devel            x86_64            3.1.9-2.el6                         base               6.7 k
 php-pecl-memcache             x86_64            3.0.5-4.el6                         base                60 k
 php-pgsql                     x86_64            5.3.3-22.el6                        base                70 k
 php-process                   x86_64            5.3.3-22.el6                        base                39 k
 php-pspell                    x86_64            5.3.3-22.el6                        base                28 k
 php-recode                    x86_64            5.3.3-22.el6                        base                25 k
 php-snmp                      x86_64            5.3.3-22.el6                        base                30 k
 php-soap                      x86_64            5.3.3-22.el6                        base               139 k
 php-tidy                      x86_64            5.3.3-22.el6                        base                35 k
 php-xml                       x86_64            5.3.3-22.el6                        base               103 k
 php-xmlrpc                    x86_64            5.3.3-22.el6                        base                52 k
 php-zts                       x86_64            5.3.3-22.el6                        base               1.2 M
Installing for dependencies:
 apr                           x86_64            1.3.9-5.el6_2                       base               123 k
 apr-util                      x86_64            1.3.9-3.el6_0.1                     base                87 k
 apr-util-ldap                 x86_64            1.3.9-3.el6_0.1                     base                15 k
 aspell                        x86_64            12:0.60.6-12.el6                    base               648 k
 autoconf                      noarch            2.63-5.1.el6                        base               781 k
 automake                      noarch            1.11.1-4.el6                        base               550 k
 enchant                       x86_64            1:1.5.0-4.el6                       base                49 k
 freetype                      x86_64            2.3.11-14.el6_3.1                   updates            359 k
 httpd                         x86_64            2.2.15-26.el6.centos                base               821 k
 httpd-tools                   x86_64            2.2.15-26.el6.centos                base                72 k
 hunspell                      x86_64            1.2.8-16.el6                        base               177 k
 libX11                        x86_64            1.5.0-4.el6                         base               584 k
 libX11-common                 noarch            1.5.0-4.el6                         base               192 k
 libXau                        x86_64            1.0.6-4.el6                         base                24 k
 libXpm                        x86_64            3.5.10-2.el6                        base                51 k
 libc-client                   x86_64            2007e-11.el6                        base               515 k
 libicu                        x86_64            4.2.1-9.1.el6_2                     base               4.9 M
 libjpeg-turbo                 x86_64            1.2.1-1.el6                         base               174 k
 libpng                        x86_64            2:1.2.49-1.el6_2                    base               182 k
 libtidy                       x86_64            0.99.0-19.20070615.1.el6            base               127 k
 libtool-ltdl                  x86_64            2.2.6-15.5.el6                      base                44 k
 libxcb                        x86_64            1.8.1-1.el6                         base               110 k
 libxslt                       x86_64            1.1.26-2.el6_3.1                    base               452 k
 lm_sensors-libs               x86_64            3.1.1-17.el6                        base                38 k
 mailcap                       noarch            2.1.31-2.el6                        base                27 k
 net-snmp                      x86_64            1:5.5-44.el6                        base               303 k
 net-snmp-libs                 x86_64            1:5.5-44.el6                        base               1.5 M
 postgresql-libs               x86_64            8.4.13-1.el6_3                      base               200 k
 recode                        x86_64            3.6-28.1.el6                        base               712 k
 unixODBC                      x86_64            2.2.14-12.el6_3                     base               378 k

Transaction Summary
==============================================================================================================
Install      61 Package(s)

Total download size: 24 M
Installed size: 82 M
Downloading Packages:
(1/61): apr-1.3.9-5.el6_2.x86_64.rpm                                                   | 123 kB     00:02
(2/61): apr-util-1.3.9-3.el6_0.1.x86_64.rpm                                            |  87 kB     00:00
(3/61): apr-util-ldap-1.3.9-3.el6_0.1.x86_64.rpm                                       |  15 kB     00:00
(4/61): aspell-0.60.6-12.el6.x86_64.rpm                                                | 648 kB     00:08
(5/61): autoconf-2.63-5.1.el6.noarch.rpm                                               | 781 kB     00:06
(6/61): automake-1.11.1-4.el6.noarch.rpm                                               | 550 kB     00:06
(7/61): enchant-1.5.0-4.el6.x86_64.rpm                                                 |  49 kB     00:00
(8/61): freetype-2.3.11-14.el6_3.1.x86_64.rpm                                          | 359 kB     00:04
(9/61): httpd-2.2.15-26.el6.centos.x86_64.rpm                                          | 821 kB     00:18
(10/61): httpd-tools-2.2.15-26.el6.centos.x86_64.rpm                                   |  72 kB     00:00
(11/61): hunspell-1.2.8-16.el6.x86_64.rpm                                              | 177 kB     00:01
(12/61): libX11-1.5.0-4.el6.x86_64.rpm                                                 | 584 kB     00:10
(13/61): libX11-common-1.5.0-4.el6.noarch.rpm                                          | 192 kB     00:01
(14/61): libXau-1.0.6-4.el6.x86_64.rpm                                                 |  24 kB     00:00
(15/61): libXpm-3.5.10-2.el6.x86_64.rpm                                                |  51 kB     00:00
(16/61): libc-client-2007e-11.el6.x86_64.rpm                                           | 515 kB     00:05
(17/61): libicu-4.2.1-9.1.el6_2.x86_64.rpm                                             | 4.9 MB     00:54
(18/61): libjpeg-turbo-1.2.1-1.el6.x86_64.rpm                                          | 174 kB     00:02
(19/61): libpng-1.2.49-1.el6_2.x86_64.rpm                                              | 182 kB     00:01
(20/61): libtidy-0.99.0-19.20070615.1.el6.x86_64.rpm                                   | 127 kB     00:01
(21/61): libtool-ltdl-2.2.6-15.5.el6.x86_64.rpm                                        |  44 kB     00:00
(22/61): libxcb-1.8.1-1.el6.x86_64.rpm                                                 | 110 kB     00:00
(23/61): libxslt-1.1.26-2.el6_3.1.x86_64.rpm                                           | 452 kB     00:03
(24/61): lm_sensors-libs-3.1.1-17.el6.x86_64.rpm                                       |  38 kB     00:01
(25/61): mailcap-2.1.31-2.el6.noarch.rpm                                               |  27 kB     00:00
(26/61): net-snmp-5.5-44.el6.x86_64.rpm                                                | 303 kB     00:03
(27/61): net-snmp-libs-5.5-44.el6.x86_64.rpm                                           | 1.5 MB     00:17
(28/61): php-5.3.3-22.el6.x86_64.rpm                                                   | 1.1 MB     00:11
(29/61): php-bcmath-5.3.3-22.el6.x86_64.rpm                                            |  34 kB     00:00
(30/61): php-cli-5.3.3-22.el6.x86_64.rpm                                               | 2.2 MB     00:24
(31/61): php-common-5.3.3-22.el6.x86_64.rpm                                            | 524 kB     00:07
(32/61): php-dba-5.3.3-22.el6.x86_64.rpm                                               |  40 kB     00:00
(33/61): php-devel-5.3.3-22.el6.x86_64.rpm                                             | 507 kB     00:04
(34/61): php-embedded-5.3.3-22.el6.x86_64.rpm                                          | 1.1 MB     00:10
(35/61): php-enchant-5.3.3-22.el6.x86_64.rpm                                           |  28 kB     00:00
(36/61): php-fpm-5.3.3-22.el6.x86_64.rpm                                               | 1.1 MB     00:11
(37/61): php-gd-5.3.3-22.el6.x86_64.rpm                                                | 106 kB     00:00
(38/61): php-imap-5.3.3-22.el6.x86_64.rpm                                              |  50 kB     00:01
(39/61): php-intl-5.3.3-22.el6.x86_64.rpm                                              |  70 kB     00:00
(40/61): php-ldap-5.3.3-22.el6.x86_64.rpm                                              |  38 kB     00:00
(41/61): php-mbstring-5.3.3-22.el6.x86_64.rpm                                          | 455 kB     00:05
(42/61): php-mysql-5.3.3-22.el6.x86_64.rpm                                             |  81 kB     00:00
(43/61): php-odbc-5.3.3-22.el6.x86_64.rpm                                              |  50 kB     00:00
(44/61): php-pdo-5.3.3-22.el6.x86_64.rpm                                               |  75 kB     00:00
(45/61): php-pear-1.9.4-4.el6.noarch.rpm                                               | 393 kB     00:12
(46/61): php-pecl-apc-3.1.9-2.el6.x86_64.rpm                                           |  96 kB     00:00
(47/61): php-pecl-apc-devel-3.1.9-2.el6.x86_64.rpm                                     | 6.7 kB     00:00
(48/61): php-pecl-memcache-3.0.5-4.el6.x86_64.rpm                                      |  60 kB     00:00
(49/61): php-pgsql-5.3.3-22.el6.x86_64.rpm                                             |  70 kB     00:00
(50/61): php-process-5.3.3-22.el6.x86_64.rpm                                           |  39 kB     00:00
(51/61): php-pspell-5.3.3-22.el6.x86_64.rpm                                            |  28 kB     00:00
(52/61): php-recode-5.3.3-22.el6.x86_64.rpm                                            |  25 kB     00:00
(53/61): php-snmp-5.3.3-22.el6.x86_64.rpm                                              |  30 kB     00:00
(54/61): php-soap-5.3.3-22.el6.x86_64.rpm                                              | 139 kB     00:01
(55/61): php-tidy-5.3.3-22.el6.x86_64.rpm                                              |  35 kB     00:00
(56/61): php-xml-5.3.3-22.el6.x86_64.rpm                                               | 103 kB     00:00
(57/61): php-xmlrpc-5.3.3-22.el6.x86_64.rpm                                            |  52 kB     00:00
(58/61): php-zts-5.3.3-22.el6.x86_64.rpm                                               | 1.2 MB     00:17
(59/61): postgresql-libs-8.4.13-1.el6_3.x86_64.rpm                                     | 200 kB     00:01
(60/61): recode-3.6-28.1.el6.x86_64.rpm                                                | 712 kB     00:06
(61/61): unixODBC-2.2.14-12.el6_3.x86_64.rpm                                           | 378 kB     00:02
--------------------------------------------------------------------------------------------------------------
Total                                                                          82 kB/s |  24 MB     04:56
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : php-common-5.3.3-22.el6.x86_64                                                            1/61
  Installing : php-pdo-5.3.3-22.el6.x86_64                                                               2/61
  Installing : apr-1.3.9-5.el6_2.x86_64                                                                  3/61
  Installing : apr-util-1.3.9-3.el6_0.1.x86_64                                                           4/61
  Installing : php-cli-5.3.3-22.el6.x86_64                                                               5/61
  Installing : 1:php-pear-1.9.4-4.el6.noarch                                                             6/61
  Installing : lm_sensors-libs-3.1.1-17.el6.x86_64                                                       7/61
  Installing : 1:net-snmp-libs-5.5-44.el6.x86_64                                                         8/61
  Installing : autoconf-2.63-5.1.el6.noarch                                                              9/61
  Installing : automake-1.11.1-4.el6.noarch                                                             10/61
  Installing : 1:net-snmp-5.5-44.el6.x86_64                                                             11/61
  Installing : php-pecl-apc-3.1.9-2.el6.x86_64                                                          12/61
  Installing : apr-util-ldap-1.3.9-3.el6_0.1.x86_64                                                     13/61
  Installing : httpd-tools-2.2.15-26.el6.centos.x86_64                                                  14/61
  Installing : libXau-1.0.6-4.el6.x86_64                                                                15/61
  Installing : libxcb-1.8.1-1.el6.x86_64                                                                16/61
  Installing : libX11-common-1.5.0-4.el6.noarch                                                         17/61
  Installing : libX11-1.5.0-4.el6.x86_64                                                                18/61
  Installing : libXpm-3.5.10-2.el6.x86_64                                                               19/61
  Installing : postgresql-libs-8.4.13-1.el6_3.x86_64                                                    20/61
  Installing : mailcap-2.1.31-2.el6.noarch                                                              21/61
  Installing : httpd-2.2.15-26.el6.centos.x86_64                                                        22/61
  Installing : php-5.3.3-22.el6.x86_64                                                                  23/61
  Installing : php-devel-5.3.3-22.el6.x86_64                                                            24/61
  Installing : 2:libpng-1.2.49-1.el6_2.x86_64                                                           25/61
  Installing : libxslt-1.1.26-2.el6_3.1.x86_64                                                          26/61
  Installing : libtool-ltdl-2.2.6-15.5.el6.x86_64                                                       27/61
  Installing : unixODBC-2.2.14-12.el6_3.x86_64                                                          28/61
  Installing : libicu-4.2.1-9.1.el6_2.x86_64                                                            29/61
  Installing : recode-3.6-28.1.el6.x86_64                                                               30/61
  Installing : libc-client-2007e-11.el6.x86_64                                                          31/61
  Installing : freetype-2.3.11-14.el6_3.1.x86_64                                                        32/61
  Installing : 12:aspell-0.60.6-12.el6.x86_64                                                           33/61
  Installing : libtidy-0.99.0-19.20070615.1.el6.x86_64                                                  34/61
  Installing : libjpeg-turbo-1.2.1-1.el6.x86_64                                                         35/61
  Installing : hunspell-1.2.8-16.el6.x86_64                                                             36/61
  Installing : 1:enchant-1.5.0-4.el6.x86_64                                                             37/61
  Installing : php-enchant-5.3.3-22.el6.x86_64                                                          38/61
  Installing : php-gd-5.3.3-22.el6.x86_64                                                               39/61
  Installing : php-tidy-5.3.3-22.el6.x86_64                                                             40/61
  Installing : php-pspell-5.3.3-22.el6.x86_64                                                           41/61
  Installing : php-imap-5.3.3-22.el6.x86_64                                                             42/61
  Installing : php-recode-5.3.3-22.el6.x86_64                                                           43/61
  Installing : php-intl-5.3.3-22.el6.x86_64                                                             44/61
  Installing : php-odbc-5.3.3-22.el6.x86_64                                                             45/61
  Installing : php-xml-5.3.3-22.el6.x86_64                                                              46/61
  Installing : php-pecl-apc-devel-3.1.9-2.el6.x86_64                                                    47/61
  Installing : php-zts-5.3.3-22.el6.x86_64                                                              48/61
  Installing : php-pgsql-5.3.3-22.el6.x86_64                                                            49/61
  Installing : php-snmp-5.3.3-22.el6.x86_64                                                             50/61
  Installing : php-pecl-memcache-3.0.5-4.el6.x86_64                                                     51/61
  Installing : php-mysql-5.3.3-22.el6.x86_64                                                            52/61
  Installing : php-bcmath-5.3.3-22.el6.x86_64                                                           53/61
  Installing : php-fpm-5.3.3-22.el6.x86_64                                                              54/61
  Installing : php-xmlrpc-5.3.3-22.el6.x86_64                                                           55/61
  Installing : php-dba-5.3.3-22.el6.x86_64                                                              56/61
  Installing : php-mbstring-5.3.3-22.el6.x86_64                                                         57/61
  Installing : php-ldap-5.3.3-22.el6.x86_64                                                             58/61
  Installing : php-process-5.3.3-22.el6.x86_64                                                          59/61
  Installing : php-soap-5.3.3-22.el6.x86_64                                                             60/61
  Installing : php-embedded-5.3.3-22.el6.x86_64                                                         61/61
  Verifying  : hunspell-1.2.8-16.el6.x86_64                                                              1/61
  Verifying  : httpd-2.2.15-26.el6.centos.x86_64                                                         2/61
  Verifying  : php-recode-5.3.3-22.el6.x86_64                                                            3/61
  Verifying  : libjpeg-turbo-1.2.1-1.el6.x86_64                                                          4/61
  Verifying  : libtidy-0.99.0-19.20070615.1.el6.x86_64                                                   5/61
  Verifying  : libxcb-1.8.1-1.el6.x86_64                                                                 6/61
  Verifying  : libXpm-3.5.10-2.el6.x86_64                                                                7/61
  Verifying  : apr-util-ldap-1.3.9-3.el6_0.1.x86_64                                                      8/61
  Verifying  : php-pecl-memcache-3.0.5-4.el6.x86_64                                                      9/61
  Verifying  : 12:aspell-0.60.6-12.el6.x86_64                                                           10/61
  Verifying  : php-bcmath-5.3.3-22.el6.x86_64                                                           11/61
  Verifying  : php-fpm-5.3.3-22.el6.x86_64                                                              12/61
  Verifying  : php-devel-5.3.3-22.el6.x86_64                                                            13/61
  Verifying  : 1:php-pear-1.9.4-4.el6.noarch                                                            14/61
  Verifying  : php-pspell-5.3.3-22.el6.x86_64                                                           15/61
  Verifying  : php-xml-5.3.3-22.el6.x86_64                                                              16/61
  Verifying  : httpd-tools-2.2.15-26.el6.centos.x86_64                                                  17/61
  Verifying  : freetype-2.3.11-14.el6_3.1.x86_64                                                        18/61
  Verifying  : php-mysql-5.3.3-22.el6.x86_64                                                            19/61
  Verifying  : php-enchant-5.3.3-22.el6.x86_64                                                          20/61
  Verifying  : libX11-1.5.0-4.el6.x86_64                                                                21/61
  Verifying  : unixODBC-2.2.14-12.el6_3.x86_64                                                          22/61
  Verifying  : automake-1.11.1-4.el6.noarch                                                             23/61
  Verifying  : php-gd-5.3.3-22.el6.x86_64                                                               24/61
  Verifying  : apr-util-1.3.9-3.el6_0.1.x86_64                                                          25/61
  Verifying  : php-tidy-5.3.3-22.el6.x86_64                                                             26/61
  Verifying  : php-cli-5.3.3-22.el6.x86_64                                                              27/61
  Verifying  : libc-client-2007e-11.el6.x86_64                                                          28/61
  Verifying  : php-common-5.3.3-22.el6.x86_64                                                           29/61
  Verifying  : 1:enchant-1.5.0-4.el6.x86_64                                                             30/61
  Verifying  : recode-3.6-28.1.el6.x86_64                                                               31/61
  Verifying  : php-pecl-apc-3.1.9-2.el6.x86_64                                                          32/61
  Verifying  : libicu-4.2.1-9.1.el6_2.x86_64                                                            33/61
  Verifying  : autoconf-2.63-5.1.el6.noarch                                                             34/61
  Verifying  : libtool-ltdl-2.2.6-15.5.el6.x86_64                                                       35/61
  Verifying  : libxslt-1.1.26-2.el6_3.1.x86_64                                                          36/61
  Verifying  : 2:libpng-1.2.49-1.el6_2.x86_64                                                           37/61
  Verifying  : mailcap-2.1.31-2.el6.noarch                                                              38/61
  Verifying  : apr-1.3.9-5.el6_2.x86_64                                                                 39/61
  Verifying  : 1:net-snmp-5.5-44.el6.x86_64                                                             40/61
  Verifying  : php-xmlrpc-5.3.3-22.el6.x86_64                                                           41/61
  Verifying  : postgresql-libs-8.4.13-1.el6_3.x86_64                                                    42/61
  Verifying  : php-odbc-5.3.3-22.el6.x86_64                                                             43/61
  Verifying  : libX11-common-1.5.0-4.el6.noarch                                                         44/61
  Verifying  : php-imap-5.3.3-22.el6.x86_64                                                             45/61
  Verifying  : php-dba-5.3.3-22.el6.x86_64                                                              46/61
  Verifying  : php-mbstring-5.3.3-22.el6.x86_64                                                         47/61
  Verifying  : php-ldap-5.3.3-22.el6.x86_64                                                             48/61
  Verifying  : php-5.3.3-22.el6.x86_64                                                                  49/61
  Verifying  : php-pecl-apc-devel-3.1.9-2.el6.x86_64                                                    50/61
  Verifying  : 1:net-snmp-libs-5.5-44.el6.x86_64                                                        51/61
  Verifying  : php-pgsql-5.3.3-22.el6.x86_64                                                            52/61
  Verifying  : php-snmp-5.3.3-22.el6.x86_64                                                             53/61
  Verifying  : libXau-1.0.6-4.el6.x86_64                                                                54/61
  Verifying  : php-pdo-5.3.3-22.el6.x86_64                                                              55/61
  Verifying  : lm_sensors-libs-3.1.1-17.el6.x86_64                                                      56/61
  Verifying  : php-process-5.3.3-22.el6.x86_64                                                          57/61
  Verifying  : php-soap-5.3.3-22.el6.x86_64                                                             58/61
  Verifying  : php-embedded-5.3.3-22.el6.x86_64                                                         59/61
  Verifying  : php-intl-5.3.3-22.el6.x86_64                                                             60/61
  Verifying  : php-zts-5.3.3-22.el6.x86_64                                                              61/61

Installed:
  php.x86_64 0:5.3.3-22.el6                             php-bcmath.x86_64 0:5.3.3-22.el6
  php-cli.x86_64 0:5.3.3-22.el6                         php-common.x86_64 0:5.3.3-22.el6
  php-dba.x86_64 0:5.3.3-22.el6                         php-devel.x86_64 0:5.3.3-22.el6
  php-embedded.x86_64 0:5.3.3-22.el6                    php-enchant.x86_64 0:5.3.3-22.el6
  php-fpm.x86_64 0:5.3.3-22.el6                         php-gd.x86_64 0:5.3.3-22.el6
  php-imap.x86_64 0:5.3.3-22.el6                        php-intl.x86_64 0:5.3.3-22.el6
  php-ldap.x86_64 0:5.3.3-22.el6                        php-mbstring.x86_64 0:5.3.3-22.el6
  php-mysql.x86_64 0:5.3.3-22.el6                       php-odbc.x86_64 0:5.3.3-22.el6
  php-pdo.x86_64 0:5.3.3-22.el6                         php-pear.noarch 1:1.9.4-4.el6
  php-pecl-apc.x86_64 0:3.1.9-2.el6                     php-pecl-apc-devel.x86_64 0:3.1.9-2.el6
  php-pecl-memcache.x86_64 0:3.0.5-4.el6                php-pgsql.x86_64 0:5.3.3-22.el6
  php-process.x86_64 0:5.3.3-22.el6                     php-pspell.x86_64 0:5.3.3-22.el6
  php-recode.x86_64 0:5.3.3-22.el6                      php-snmp.x86_64 0:5.3.3-22.el6
  php-soap.x86_64 0:5.3.3-22.el6                        php-tidy.x86_64 0:5.3.3-22.el6
  php-xml.x86_64 0:5.3.3-22.el6                         php-xmlrpc.x86_64 0:5.3.3-22.el6
  php-zts.x86_64 0:5.3.3-22.el6

Dependency Installed:
  apr.x86_64 0:1.3.9-5.el6_2                           apr-util.x86_64 0:1.3.9-3.el6_0.1
  apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1               aspell.x86_64 12:0.60.6-12.el6
  autoconf.noarch 0:2.63-5.1.el6                       automake.noarch 0:1.11.1-4.el6
  enchant.x86_64 1:1.5.0-4.el6                         freetype.x86_64 0:2.3.11-14.el6_3.1
  httpd.x86_64 0:2.2.15-26.el6.centos                  httpd-tools.x86_64 0:2.2.15-26.el6.centos
  hunspell.x86_64 0:1.2.8-16.el6                       libX11.x86_64 0:1.5.0-4.el6
  libX11-common.noarch 0:1.5.0-4.el6                   libXau.x86_64 0:1.0.6-4.el6
  libXpm.x86_64 0:3.5.10-2.el6                         libc-client.x86_64 0:2007e-11.el6
  libicu.x86_64 0:4.2.1-9.1.el6_2                      libjpeg-turbo.x86_64 0:1.2.1-1.el6
  libpng.x86_64 2:1.2.49-1.el6_2                       libtidy.x86_64 0:0.99.0-19.20070615.1.el6
  libtool-ltdl.x86_64 0:2.2.6-15.5.el6                 libxcb.x86_64 0:1.8.1-1.el6
  libxslt.x86_64 0:1.1.26-2.el6_3.1                    lm_sensors-libs.x86_64 0:3.1.1-17.el6
  mailcap.noarch 0:2.1.31-2.el6                        net-snmp.x86_64 1:5.5-44.el6
  net-snmp-libs.x86_64 1:5.5-44.el6                    postgresql-libs.x86_64 0:8.4.13-1.el6_3
  recode.x86_64 0:3.6-28.1.el6                         unixODBC.x86_64 0:2.2.14-12.el6_3

Complete!

2. Check and verify the installed PHP packages :

[root@centos64 ~]# rpm -qa | grep php
php-gd-5.3.3-22.el6.x86_64
php-pspell-5.3.3-22.el6.x86_64
php-recode-5.3.3-22.el6.x86_64
php-odbc-5.3.3-22.el6.x86_64
php-pecl-apc-devel-3.1.9-2.el6.x86_64
php-pgsql-5.3.3-22.el6.x86_64
php-pecl-memcache-3.0.5-4.el6.x86_64
php-bcmath-5.3.3-22.el6.x86_64
php-xmlrpc-5.3.3-22.el6.x86_64
php-mbstring-5.3.3-22.el6.x86_64
php-process-5.3.3-22.el6.x86_64
php-embedded-5.3.3-22.el6.x86_64
php-pdo-5.3.3-22.el6.x86_64
php-pear-1.9.4-4.el6.noarch
php-pecl-apc-3.1.9-2.el6.x86_64
php-devel-5.3.3-22.el6.x86_64
php-enchant-5.3.3-22.el6.x86_64
php-tidy-5.3.3-22.el6.x86_64
php-imap-5.3.3-22.el6.x86_64
php-intl-5.3.3-22.el6.x86_64
php-xml-5.3.3-22.el6.x86_64
php-zts-5.3.3-22.el6.x86_64
php-snmp-5.3.3-22.el6.x86_64
php-mysql-5.3.3-22.el6.x86_64
php-fpm-5.3.3-22.el6.x86_64
php-dba-5.3.3-22.el6.x86_64
php-ldap-5.3.3-22.el6.x86_64
php-soap-5.3.3-22.el6.x86_64
php-common-5.3.3-22.el6.x86_64
php-cli-5.3.3-22.el6.x86_64
php-5.3.3-22.el6.x86_64

3. Verify PHP Version :

[root@centos64 ~]# php -v
PHP 5.3.3 (cli) (built: Feb 22 2013 02:51:11)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

4. Do backup original php.ini :

[root@centos64 ~]# cp -a /etc/php.ini /etc/php.ini.15032013

5. Configure PHP :

[root@centos64 ~]# vi /etc/php.ini

a. Increase PHP script memory limit :

memory_limit = 128M

b. ncrease PHP script max execution time :

max_execution_time = 120

c. Increase PHP script max upload size :

upload_max_filesize = 50M

6. Restart Apache Server :

[root@centos64 ~]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

4 Steps to Disable SELinux on CentOS 6.4

There are four easy steps to disable Security-Enhanced Linux (SELinux) on CentOS 6.4. The steps was very simple, but if we did not disable this feature, you may hit a problem when try to do software installation. SELinux checking for allowed operations after standard Linux discretionary access controls are checked. Follow below steps to disable SELinux on CentOS 6.4.

1. Check selinux status :

[root@centos64 ~]# sestatus
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   enforcing
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted

2. Disable SELinux immediately without reboot :

[root@centos64 ~]# setenforce 0

3. Disable SELinux on CentOS 6.4 permanently :

[root@centos64 ~]# vi /etc/sysconfig/selinux

Change “SELINUX=enforcing” to “SELINUX=disabled” :

# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#     enforcing - SELinux security policy is enforced.
#     permissive - SELinux prints warnings instead of enforcing.
#     disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#     targeted - Targeted processes are protected,
#     mls - Multi Level Security protection.
SELINUXTYPE=targeted

4. Reboot Operating system :

[root@centos64 ~]# reboot

How to Uninstall VMware Tools on Linux, Solaris, FreeBSD

Question :
How to Uninstall VMware Tools if upgrade of VMware Tools is incomplete and i got hit by any problem during installation ?

Answer :
Option 1 :
On a Linux guest operating system that has VMware Tools installed by using an RPM installer, enter the following command in a terminal :

[root@centos64 ~]# rpm -e VMwareTools

Option 2 :
On a Linux, Solaris, FreeBSD, NetWare guest operating system that has VMware Tools installed by vmware-install.pl, please log in as root and enter the following command in a terminal :

[root@centos64 ~]# vmware-uninstall-tools.pl

Example :

[root@centos64 ~]# vmware-uninstall-tools.pl
Uninstalling the tar installation of VMware Tools.

Stopping services for vmware-tools

initctl: Unknown instance:
Stopping services for vmware-tools-thinprint

initctl: Unknown instance:
This program previously created the file
/usr/lib/vmware-tools/lib64/libconf/etc/pango/pango.modules, and was about to
remove it.  Somebody else apparently did it already.

File /etc/vmware-tools/vmware-user.desktop is backed up to
/etc/vmware-tools/vmware-user.desktop.old.0.

File /usr/lib/vmware-tools/lib64/libconf/etc/gtk-2.0/gtk.immodules is backed up
to /usr/lib/vmware-tools/lib64/libconf/etc/gtk-2.0/gtk.immodules.old.0.

File /usr/lib/vmware-tools/lib64/libconf/etc/gtk-2.0/gdk-pixbuf.loaders is
backed up to
/usr/lib/vmware-tools/lib64/libconf/etc/gtk-2.0/gdk-pixbuf.loaders.old.0.

This program previously created the file
/usr/lib/vmware-tools/libconf/etc/gtk-2.0/gdk-pixbuf.loaders, and was about to
remove it.  Somebody else apparently did it already.

This program previously created the file
/usr/lib/vmware-tools/lib64/libconf/etc/pango/pangorc, and was about to remove
it.  Somebody else apparently did it already.

This program previously created the file
/usr/lib/vmware-tools/libconf/etc/gtk-2.0/gtk.immodules, and was about to
remove it.  Somebody else apparently did it already.

This program previously created the file
/usr/lib/vmware-tools/lib64/libconf/etc/pango/pangox.aliases, and was about to
remove it.  Somebody else apparently did it already.

This program previously created the directory
/usr/lib/vmware-tools/lib64/libconf/etc/gtk-2.0, and was about to remove it.
Since there are files in that directory that this program did not create, it
will not be removed.

This program previously created the directory
/usr/lib/vmware-tools/lib64/libconf/etc, and was about to remove it. Since
there are files in that directory that this program did not create, it will not
be removed.

This program previously created the directory
/usr/lib/vmware-tools/lib64/libconf, and was about to remove it. Since there
are files in that directory that this program did not create, it will not be
removed.

This program previously created the directory /usr/lib/vmware-tools/lib64, and
was about to remove it. Since there are files in that directory that this
program did not create, it will not be removed.

This program previously created the directory /usr/lib/vmware-tools, and was
about to remove it. Since there are files in that directory that this program
did not create, it will not be removed.

The removal of VMware Tools 9.2.2 build-893683 for Linux completed
successfully.  Thank you for having tried this software.

How to Install VMware Tools on CentOS 6.4

vmware-toolsThis post provides steps to install VMware Tools in CentOS 6.4. It is very important to install VMware Tools in the guest operating system. Without the VMware Tools, guest OS performance will lacks some of the important functionality. VMware Tools is a group of utilities that enhances the overall performance of the virtual machine’s guest operating system (OS) and improves management of the virtual machine (VM). This is one of important components in order to provide perfect VM OS.

1. Choose your VM –> Click “Install VMware Tools” from the VMware Workstation menu, VMware Workstation temporarily connects the virtual machine’s first virtual CD-ROM drive to the ISO image file that contains the VMware Tools installer for your guest operating system and you are ready to begin the installation process.

2. Install prerequisites :

[root@centos64 ~]# yum install perl gcc make -y

Example :

[root@centos64 ~]# yum install perl gcc make -y
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.ipserverone.com
 * extras: centos.ipserverone.com
 * updates: centos.ipserverone.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.4.7-3.el6 will be installed
--> Processing Dependency: libgomp = 4.4.7-3.el6 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: cpp = 4.4.7-3.el6 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: cloog-ppl >= 0.15 for package: gcc-4.4.7-3.el6.x86_64
--> Processing Dependency: libgomp.so.1()(64bit) for package: gcc-4.4.7-3.el6.x86_64
---> Package make.x86_64 1:3.81-20.el6 will be installed
---> Package perl.x86_64 4:5.10.1-129.el6 will be installed
--> Processing Dependency: perl-libs = 4:5.10.1-129.el6 for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(version) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-129.el6.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-129.el6.x86_64
--> Running transaction check
---> Package cloog-ppl.x86_64 0:0.15.7-1.2.el6 will be installed
--> Processing Dependency: libppl_c.so.2()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
--> Processing Dependency: libppl.so.7()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64
---> Package cpp.x86_64 0:4.4.7-3.el6 will be installed
--> Processing Dependency: libmpfr.so.1()(64bit) for package: cpp-4.4.7-3.el6.x86_64
---> Package glibc-devel.x86_64 0:2.12-1.107.el6 will be installed
--> Processing Dependency: glibc-headers = 2.12-1.107.el6 for package: glibc-devel-2.12-1.107.el6.x86_64
--> Processing Dependency: glibc-headers for package: glibc-devel-2.12-1.107.el6.x86_64
---> Package libgomp.x86_64 0:4.4.7-3.el6 will be installed
---> Package perl-Module-Pluggable.x86_64 1:3.90-129.el6 will be installed
---> Package perl-Pod-Simple.x86_64 1:3.13-129.el6 will be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-129.el6.x86_64
---> Package perl-libs.x86_64 4:5.10.1-129.el6 will be installed
---> Package perl-version.x86_64 3:0.77-129.el6 will be installed
--> Running transaction check
---> Package glibc-headers.x86_64 0:2.12-1.107.el6 will be installed
--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.12-1.107.el6.x86_64
--> Processing Dependency: kernel-headers for package: glibc-headers-2.12-1.107.el6.x86_64
---> Package mpfr.x86_64 0:2.4.1-6.el6 will be installed
---> Package perl-Pod-Escapes.x86_64 1:1.04-129.el6 will be installed
---> Package ppl.x86_64 0:0.10.2-11.el6 will be installed
--> Running transaction check
---> Package kernel-headers.x86_64 0:2.6.32-358.2.1.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================
 Package                          Arch              Version                          Repository          Size
==============================================================================================================
Installing:
 gcc                              x86_64            4.4.7-3.el6                      base                10 M
 make                             x86_64            1:3.81-20.el6                    base               389 k
 perl                             x86_64            4:5.10.1-129.el6                 base                10 M
Installing for dependencies:
 cloog-ppl                        x86_64            0.15.7-1.2.el6                   base                93 k
 cpp                              x86_64            4.4.7-3.el6                      base               3.7 M
 glibc-devel                      x86_64            2.12-1.107.el6                   base               974 k
 glibc-headers                    x86_64            2.12-1.107.el6                   base               604 k
 kernel-headers                   x86_64            2.6.32-358.2.1.el6               updates            2.3 M
 libgomp                          x86_64            4.4.7-3.el6                      base               118 k
 mpfr                             x86_64            2.4.1-6.el6                      base               157 k
 perl-Module-Pluggable            x86_64            1:3.90-129.el6                   base                38 k
 perl-Pod-Escapes                 x86_64            1:1.04-129.el6                   base                31 k
 perl-Pod-Simple                  x86_64            1:3.13-129.el6                   base               210 k
 perl-libs                        x86_64            4:5.10.1-129.el6                 base               576 k
 perl-version                     x86_64            3:0.77-129.el6                   base                50 k
 ppl                              x86_64            0.10.2-11.el6                    base               1.3 M

Transaction Summary
==============================================================================================================
Install      16 Package(s)

Total download size: 31 M
Installed size: 75 M
Downloading Packages:
(1/16): cloog-ppl-0.15.7-1.2.el6.x86_64.rpm                                            |  93 kB     00:01
(2/16): cpp-4.4.7-3.el6.x86_64.rpm                                                     | 3.7 MB     00:36
(3/16): gcc-4.4.7-3.el6.x86_64.rpm                                                     |  10 MB     01:36
(4/16): glibc-devel-2.12-1.107.el6.x86_64.rpm                                          | 974 kB     00:08
(5/16): glibc-headers-2.12-1.107.el6.x86_64.rpm                                        | 604 kB     00:10
(6/16): kernel-headers-2.6.32-358.2.1.el6.x86_64.rpm                                   | 2.3 MB     00:23
(7/16): libgomp-4.4.7-3.el6.x86_64.rpm                                                 | 118 kB     00:00
(8/16): make-3.81-20.el6.x86_64.rpm                                                    | 389 kB     00:03
(9/16): mpfr-2.4.1-6.el6.x86_64.rpm                                                    | 157 kB     00:01
(10/16): perl-5.10.1-129.el6.x86_64.rpm                                                |  10 MB     01:40
(11/16): perl-Module-Pluggable-3.90-129.el6.x86_64.rpm                                 |  38 kB     00:00
(12/16): perl-Pod-Escapes-1.04-129.el6.x86_64.rpm                                      |  31 kB     00:00
(13/16): perl-Pod-Simple-3.13-129.el6.x86_64.rpm                                       | 210 kB     00:02
(14/16): perl-libs-5.10.1-129.el6.x86_64.rpm                                           | 576 kB     00:05
(15/16): perl-version-0.77-129.el6.x86_64.rpm                                          |  50 kB     00:00
(16/16): ppl-0.10.2-11.el6.x86_64.rpm                                                  | 1.3 MB     00:11
--------------------------------------------------------------------------------------------------------------
Total                                                                         103 kB/s |  31 MB     05:06
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : 1:perl-Pod-Escapes-1.04-129.el6.x86_64                                                    1/16
  Installing : 4:perl-libs-5.10.1-129.el6.x86_64                                                         2/16
  Installing : 3:perl-version-0.77-129.el6.x86_64                                                        3/16
  Installing : 1:perl-Module-Pluggable-3.90-129.el6.x86_64                                               4/16
  Installing : 1:perl-Pod-Simple-3.13-129.el6.x86_64                                                     5/16
  Installing : 4:perl-5.10.1-129.el6.x86_64                                                              6/16
  Installing : ppl-0.10.2-11.el6.x86_64                                                                  7/16
  Installing : cloog-ppl-0.15.7-1.2.el6.x86_64                                                           8/16
  Installing : kernel-headers-2.6.32-358.2.1.el6.x86_64                                                  9/16
  Installing : glibc-headers-2.12-1.107.el6.x86_64                                                      10/16
  Installing : glibc-devel-2.12-1.107.el6.x86_64                                                        11/16
  Installing : libgomp-4.4.7-3.el6.x86_64                                                               12/16
  Installing : mpfr-2.4.1-6.el6.x86_64                                                                  13/16
  Installing : cpp-4.4.7-3.el6.x86_64                                                                   14/16
  Installing : gcc-4.4.7-3.el6.x86_64                                                                   15/16
  Installing : 1:make-3.81-20.el6.x86_64                                                                16/16
  Verifying  : glibc-devel-2.12-1.107.el6.x86_64                                                         1/16
  Verifying  : gcc-4.4.7-3.el6.x86_64                                                                    2/16
  Verifying  : 1:perl-Pod-Escapes-1.04-129.el6.x86_64                                                    3/16
  Verifying  : 1:perl-Pod-Simple-3.13-129.el6.x86_64                                                     4/16
  Verifying  : mpfr-2.4.1-6.el6.x86_64                                                                   5/16
  Verifying  : libgomp-4.4.7-3.el6.x86_64                                                                6/16
  Verifying  : 4:perl-5.10.1-129.el6.x86_64                                                              7/16
  Verifying  : 4:perl-libs-5.10.1-129.el6.x86_64                                                         8/16
  Verifying  : cpp-4.4.7-3.el6.x86_64                                                                    9/16
  Verifying  : 1:make-3.81-20.el6.x86_64                                                                10/16
  Verifying  : 3:perl-version-0.77-129.el6.x86_64                                                       11/16
  Verifying  : 1:perl-Module-Pluggable-3.90-129.el6.x86_64                                              12/16
  Verifying  : kernel-headers-2.6.32-358.2.1.el6.x86_64                                                 13/16
  Verifying  : ppl-0.10.2-11.el6.x86_64                                                                 14/16
  Verifying  : cloog-ppl-0.15.7-1.2.el6.x86_64                                                          15/16
  Verifying  : glibc-headers-2.12-1.107.el6.x86_64                                                      16/16

Installed:
  gcc.x86_64 0:4.4.7-3.el6          make.x86_64 1:3.81-20.el6          perl.x86_64 4:5.10.1-129.el6

Dependency Installed:
  cloog-ppl.x86_64 0:0.15.7-1.2.el6                     cpp.x86_64 0:4.4.7-3.el6
  glibc-devel.x86_64 0:2.12-1.107.el6                   glibc-headers.x86_64 0:2.12-1.107.el6
  kernel-headers.x86_64 0:2.6.32-358.2.1.el6            libgomp.x86_64 0:4.4.7-3.el6
  mpfr.x86_64 0:2.4.1-6.el6                             perl-Module-Pluggable.x86_64 1:3.90-129.el6
  perl-Pod-Escapes.x86_64 1:1.04-129.el6                perl-Pod-Simple.x86_64 1:3.13-129.el6
  perl-libs.x86_64 4:5.10.1-129.el6                     perl-version.x86_64 3:0.77-129.el6
  ppl.x86_64 0:0.10.2-11.el6

Complete!

3. Reboot VM.

[root@centos64 ~]# reboot

4. Mount the installer.

[root@centos64 ~]# mount -t iso9660 /dev/cdrom /mnt
mount: block device /dev/sr0 is write-protected, mounting read-only

5. Copy the installer to /tmp :

[root@centos64 ~]# cd /mnt
[root@centos64 mnt]# cp VMwareTools-9.2.2-893683.tar.gz /tmp

6. Extract the installer :

[root@centos64 ~]# cd /tmp
[root@centos64 tmp]# tar xzvf VMwareTools-9.2.2-893683.tar.gz

7. Enter the vmware-tools-distrib directory :

[root@centos64 tmp]# cd vmware-tools-distrib/

8. Install the VMware Tools :

[root@centos64 vmware-tools-distrib]# ./vmware-install.pl

Download CentOS 6.4 x86_64 and x86 ISO

CentOS 6.4 has been released 9th March 2013. As we know, CentOS is an Enterprise-class Linux Distribution derived from sources freely provided to the public. It has 100% binary compatibility with its upstream source, Red Hat Enterprise Linux (RHEL).

Released Note :
http://wiki.centos.org/Manuals/ReleaseNotes/CentOS6.4

Download URL for x86 and x64 ISO
http://isoredirect.centos.org/centos/6/isos/i386/
http://isoredirect.centos.org/centos/6/isos/x86_64/

Install Media and sha1sum :

sha1sum i386:

4bd3a1de6f6dfcd7a2199487abf5a9304d696cae  CentOS-6.4-i386-bin-DVD1.iso
fb096cd6ac88959a287256c76c7292ae2ef53f32  CentOS-6.4-i386-bin-DVD2.iso
ddb63a0af2c1d63b8e9b7342c7f52a86b1842689  CentOS-6.4-i386-minimal.iso
6ffc9f3a5f4332b55cc35f1eb3ebb39f5aa8edb6  CentOS-6.4-i386-netinstall.iso

sha1sum x86_64:

8672dc087f1b0eda60b9efaa41b82f034f185e24  CentOS-6.4-x86_64-bin-DVD1.iso
db16ec15897dcb7a01e7434486075f43ca982c4b  CentOS-6.4-x86_64-bin-DVD2.iso
6232efa014d9c6798396b63152c4c9a08b279f5e  CentOS-6.4-x86_64-minimal.iso
77817ed6e879da155b6f3dc98e0698e8993e28f8  CentOS-6.4-x86_64-netinstall.iso

7 Useful Linux Utilities

Linux UtilitiesThere are 7 useful linux utilities that you must install on new linux server. Most Linux distributions are equipped with tons of linux command utility, but if you have installed minimal operating system, all these software will not exist. These tools will very useful in your troubleshooting and will help to find possible causes of a problem. Most of the utilities have the same function in CentOS or Red Hat Enterprise Linux (RHEL).

You can easily identify whether the utility installed on your linux operating system or not. You will see one or more below warning :

[root@rhel62 ~]# wget
-bash: wget: command not found
[root@rhel62 ~]# telnet
-bash: telnet: command not found
[root@rhel62 ~]# scp
-bash: scp: command not found
[root@rhel62 ~]# man scp
-bash: man: command not found
[root@rhel62 ~]# nslookup
-bash: nslookup: command not found
[root@rhel62 ~]# dig
-bash: dig: command not found
[root@rhel62 ~]# host
-bash: host: command not found

7 Useful Linux Utilities

1. What is wget ?
Wget is a network utility to retrieve files from the Web using http and ftp, the two most widely used Internet protocols.

Example :

[root@rhel62 ~]# wget http://files2.zimbra.com/downloads/8.0.2_GA/zcs-8.0.2_GA_5569.RHEL6_64.20121210115059.tgz

2. What is telnet ?
Telnet is a network protocol used on the Internet or local area networks. Telnet is a user command and an underlying TCP/IP protocol for accessing remote computers and very useful for troubleshooting and verify the opened ports.

Example :

[root@rhel62 ~]# telnet localhost 25
Trying ::1...
Connected to localhost.
Escape character is '^]'.
220 rhel62.ehowstuff.local ESMTP Postfix

3. What is scp ?
scp also call secure copy, is remote file copy utility between hosts on a network. It uses ssh for data transfer and provides the same authentication and same level of security as ssh.

Example :

[root@rhel62 ~]# scp root@192.168.2.60:/tmp/VMwareTools-9.2.2-893683.tar.gz .
The authenticity of host '192.168.2.60 (192.168.2.60)' can't be established.
RSA key fingerprint is 76:78:87:36:44:c1:46:fa:c4:b4:61:4a:e5:b3:be:e3.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.2.60' (RSA) to the list of known hosts.
root@192.168.2.60's password:
VMwareTools-9.2.2-893683.tar.gz                                                       100%   63MB  63.3MB/s   00:01

4. What is man ?
man is used to display the manual page for other commands It’s help to explain the functions for the commands that commonly used. The term “man” is short for manual.

Example :

[root@rhel62 ~]# man wget
WGET(1)                            GNU Wget                            WGET(1)

NAME
       Wget - The non-interactive network downloader.

SYNOPSIS
       wget [option]... [URL]...

DESCRIPTION
       GNU Wget is a free utility for non-interactive download of files from the Web.  It supports HTTP,
       HTTPS, and FTP protocols, as well as retrieval through HTTP proxies.

       Wget is non-interactive, meaning that it can work in the background, while the user is not logged on.
       This allows you to start a retrieval and disconnect from the system, letting Wget finish the work.
       By contrast, most of the Web browsers require constant userâs presence, which can be a great
       hindrance when transferring a lot of data.

       Wget can follow links in HTML, XHTML, and CSS pages, to create local versions of remote web sites,
       fully recreating the directory structure of the original site.  This is sometimes referred to as
       "recursive downloading."  While doing that, Wget respects the Robot Exclusion Standard (/robots.txt).
       Wget can be instructed to convert the links in downloaded files to point at the local files, for
       offline viewing.

5. What is nslookup, dig, host ?
nslookup, dig and host are part of the bind utilities.These utilities are the basic tools for DNS client and DNS server troubleshooting.

Examples :

[root@rhel62 ~]# nslookup
> set type=mx
> ehowstuff.com
Server:         8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
ehowstuff.com   mail exchanger = 0 ehowstuff.com.

Authoritative answers can be found from:
>
[root@rhel62 ~]# dig ehowstuff.com

; < <>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6 < <>> ehowstuff.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<
[root@rhel62 ~]# host -t mx ehowstuff.com
ehowstuff.com mail is handled by 0 ehowstuff.com.

How to install wget, scpt, telnet, man, nslookup, dig and host utilities ?

Simply run the following commands :

[root@rhel62 ~]# yum install wget telnet openssh-clients bind-utils man -y